Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Kali Linux 2.0 - Problem z pakietami.
#1
Exclamation 
Witam, wczoraj zainstalowalem kali linux 2.0 a nastepnie zaktualizowalem.
Teraz potrzebuje zainstalowac program wine do LOIC. Znalazlem krotki poradnik jak zainstalowac: https://longren.io/how-to-use-low-orbit-...-on-linux/

I na samym poczatku mam problem z poleceniem: sudo apt-get install monodevelop mono-gmcs mono-mcs liblog4net-cil-dev
po wpisaniu:

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu monodevelop
E: Nie udało się odnaleźć pakietu mono-gmcs
E: Nie udało się odnaleźć pakietu mono-mcs
E: Nie udało się odnaleźć pakietu liblog4net-cil-dev

tak samo jest z kazdym innym pakietem

Bardzo prosze o pomoc
Odpowiedz
#2
(01-22-2016, 18:18)roottoor napisał(a): Witam, wczoraj zainstalowalem kali linux 2.0 a nastepnie zaktualizowalem.
Teraz potrzebuje zainstalowac program wine do LOIC. Znalazlem krotki poradnik jak zainstalowac: https://longren.io/how-to-use-low-orbit-...-on-linux/

I na samym poczatku mam problem z poleceniem: sudo apt-get install monodevelop mono-gmcs mono-mcs liblog4net-cil-dev
po wpisaniu:

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu monodevelop
E: Nie udało się odnaleźć pakietu mono-gmcs
E: Nie udało się odnaleźć pakietu mono-mcs
E: Nie udało się odnaleźć pakietu liblog4net-cil-dev

tak samo jest z kazdym innym pakietem

Bardzo prosze o pomoc
Odpowiedz
#3
jeżeli to masz na wirtualnej maszynie masz szczęście
gorzej jest jak testujesz to na żywym kompie ..... będzie to bolało
W-ine jest to temat rzeka i nie ma 100% powodzenia

życzę powodzenia

aktualizacja jądra i dystrybucji czasami daje radę
Odpowiedz
#4
A wiec tak, to po pierwsze

Kod:
sudo dpkg --add-architecture i386

następnie


Kod:
apt-get update


a później

Kod:
apt-get install wine-bin:i386

i dalej

Kod:
sudo apt-get install monodevelop mono-gmcs mono-mcs liblog4net-cil-dev

Jak nie znajdziesz to prosze link


Kod:
gitclone https://github.com/NewEraCracker/LOIC

przechodzimy do katalogu LOIC

Kod:
./loic.sh

i użyj (do Ciebie należy co wybierzesz)

Kod:
Usage: ./loic.sh <install|update|ru

Po instalacji systemu trzeba edytować sources.list


Kod:
leafpad /etc/apt/sources.list


Kod:
# Regular repositories
deb http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security sana/updates main contrib non-free
# Source repositories
deb-src http://http.kali.org/kali sana main non-free contrib
deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

klik Ctrl+S i Ctrl+Q

Kod:
 apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y


Po bólu. Pozdrawiam.
Odpowiedz
#5
Teraz mam problem z tym:
sudo apt-get install monodevelop mono-gmcs mono-mcs liblog4net-cil-dev
po wklepaniu:
Następujące pakiety mają niespełnione zależności:
mono-gmcs : Wymaga: mono-mcs (= 3.12.1-0xamarin1) ale 4.2.1.102+dfsg2-5 ma zostać zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
Odpowiedz
#6
ai
(01-24-2016, 13:28)roottoor napisał(a): Teraz mam problem z tym:
sudo apt-get install monodevelop mono-gmcs mono-mcs liblog4net-cil-dev
po wklepaniu:
Następujące pakiety mają niespełnione zależności:
mono-gmcs : Wymaga: mono-mcs (= 3.12.1-0xamarin1) ale 4.2.1.102+dfsg2-5 ma zostać zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Zainstaluj to

Kod:
apt-get install git-core monodevelop

Przejdź dalej.
Odpowiedz
#7
root@Hitman:~/loic# ./loic.sh install
/usr/bin/git
MonoDevelop Build Tool
Otwieranie rozwiązania: /root/loic/LOIC/LOIC.sln
Otwieranie rozwiązania: /root/loic/LOIC/LOIC.sln
Loading projects ..
Building Solution: LOIC (Debug)
Building: IRC (Debug)
error: /root/loic/LOIC/IRC/IRC.csproj: /root/loic/LOIC/IRC/IRC.csproj could not import "$(MSBuildToolsPath)\Microsoft.CSharp.targets"
Odpowiedz
#8
(01-24-2016, 14:34)roottoor napisał(a): root@Hitman:~/loic# ./loic.sh install
/usr/bin/git
MonoDevelop Build Tool
Otwieranie rozwiązania: /root/loic/LOIC/LOIC.sln
  Otwieranie rozwiązania: /root/loic/LOIC/LOIC.sln
     Loading projects ..
Building Solution: LOIC (Debug)
  Building: IRC (Debug)
error: /root/loic/LOIC/IRC/IRC.csproj: /root/loic/LOIC/IRC/IRC.csproj could not import "$(MSBuildToolsPath)\Microsoft.CSharp.targets"

A to wklepałeś

Kod:
chmod a+x loic.sh
Odpowiedz
#9
tak wklepalem
Odpowiedz
#10
error: /root/loic/LOIC/IRC/IRC.csproj: /root/loic/LOIC/IRC/IRC.csproj could not import "$(MSBuildToolsPath)\Microsoft.CSharp.targets"


Poszukaj w katalogach tego IRC.csproj, otwórz np gedit lub leafpad, Ctrl+F wklejasz to
Kod:
Import Project


masz tam
Kod:
MSBuildToolsPath


zmień na to 


Kod:
MSBuildBinPath

Może pomoże.
Odpowiedz


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Kali 109 ustawienia TOR marcindt 18 2,431 09-06-2016, 21:30
Ostatni post: Gilley
  Iso -> pendrive with linux. problem z DD? Gilley 6 387 07-29-2016, 16:10
Ostatni post: Gilley
  Problem z przydzieleniem partycji pod Kali Hubikusek 1 391 03-27-2016, 14:39
Ostatni post: programistacpp
  Kali 2.0 - problem z wentylatorem dante32 2 893 12-16-2015, 15:17
Ostatni post: m0ses
  Instalacja Kali Linux na USB ssn 5 1,851 12-11-2015, 18:21
Ostatni post: bronekb
  linux + root bronekb 1 754 12-06-2015, 0:13
Ostatni post: n0me
  kernel linux 4.3 problem ? aktualizacja bronekb 3 868 12-04-2015, 21:25
Ostatni post: bronekb
  Linux Mint 17.2 Xenovious 5 1,304 10-01-2015, 20:04
Ostatni post: Xenovious
  Manjaro Linux 3.18 - Losowe kernel panic marcin5747 1 673 07-29-2015, 23:43
Ostatni post: marcin5747
Exclamation Problem z partycjonowaniem G4m3killer 2 728 06-15-2015, 8:42
Ostatni post: kordex

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości
stat4u