Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
MITMF problem
#1
witam, mam problem z mitmf-em, a dokładniej z jego działaniem. Chodzi o to, że gdy włączę go to komputer którego IP podaje w targecie przestaje łączyć się z siecią, sprawdziłem na 2 innych komputerach w sieci i to samo. W terminalu wpisuje:
# ./mitmf.py -i wlan1 --target 192.168.0.10 --gateway 192.168.0.1 --arp --spoof --hsts    

forwardowanie działa.
Przed reinstalacją Kali, wszystko robiłem tak samo i działało.
Może wie ktoś o co chodzi?
Odpowiedz
#2
Jeśli masz Kali 2.0 Sana to zmień polecenie na "wlan1mon"
Odpowiedz
#3
(11-11-2015, 23:11)WiFiSlax napisał(a): Jeśli masz Kali 2.0 Sana   to zmień  polecenie  na "wlan1mon"

niestety nic nie dało, a i przypomniało mi się za każym razem kiedy przerwę działanie mtimf-a i ponownie chcę rozpocząć wyskakuje błąd:
Error: could not resolve Gateway's mac address
Komputery, które próbowałem sniffować nie mają dostępu do sieci mimo przerwania programu
Odpowiedz
#4
(11-11-2015, 23:39)casius napisał(a):
(11-11-2015, 23:11)WiFiSlax napisał(a): Jeśli masz Kali 2.0 Sana   to zmień  polecenie  na "wlan1mon"

niestety nic nie dało, a i przypomniało mi się za każym razem kiedy przerwę działanie mtimf-a i ponownie chcę rozpocząć wyskakuje błąd:
Error: could not resolve Gateway's mac address
Komputery, które próbowałem sniffować nie mają dostępu do sieci mimo przerwania programu

Sprawdź czy masz dokladnie wszystkie paczki (i wersje tych paczek) z pliku requirements.txt. Jeśli nie to zrób dokladnie takie wersje jak w tym pliku.
"Life would be tragic if it weren't funny."
Stephen Hawking
Odpowiedz
#5
(11-29-2015, 10:07)m0ses napisał(a):
(11-11-2015, 23:39)casius napisał(a):
(11-11-2015, 23:11)WiFiSlax napisał(a): Jeśli masz Kali 2.0 Sana   to zmień  polecenie  na "wlan1mon"

niestety nic nie dało, a i przypomniało mi się za każym razem kiedy przerwę działanie mtimf-a i ponownie chcę rozpocząć wyskakuje błąd:
Error: could not resolve Gateway's mac address
Komputery, które próbowałem sniffować nie mają dostępu do sieci mimo przerwania programu

Sprawdź czy masz dokladnie wszystkie paczki (i wersje tych paczek) z pliku requirements.txt. Jeśli nie to zrób dokladnie takie wersje jak w tym pliku.
Sprawdziłem jeszcze raz, i na virtualnym i na normalnym. Zainstalowałem wszystko. Ale wogóle to jakaś dziwna sytuacja jest, czasami zbiera ale pochodzi chwilę i staje, a net w sniffowanym kompie rozłącza. Tak samo dzieje się jesli robię :ręcznie" przez samego arpspoofa i sslstreama z dns2proxy - chwilę chodzi normalnie po czym to samo co na mitmf-ie. Nie wiem czy to ma znaczenie ale sniffuje podłaczony telefon.
Odpowiedz
#6
Mam identyczny problem. "czasami zbiera ale pochodzi chwilę i staje, a net w sniffowanym kompie rozłącza"
Używałem ettercapa, arpspoofa i efekt ten sam. Zbierze 2 pakiety i rozłącza neta. MAC bramy dobrze się zmienia na ofierze. Subterfuge wgl nie działa.

Dodam, że od dłuższego czasu bawie się zantim na androidzie (spoofer na arp, więc zasada ta sama) I działa idealnie. Internet śmiga na podsłuchiwanych kompach, nie wyskakują błędy "Nieważny certyfikat" jak w ettercapie. Zamienia https na http. Nawet można przejąć sesje jednym kliknięciem.
Jako że chce się uczyć, szukam jak osiągnąć ten sam efekt. ale na kalim. Niestety nic nie działa. Jakby pakiety, które przechwyciłem nie trafiały do docelowego urządzenia. Troche dziwne że apka na fona działa o niebo lepiej niż popularny ettercap.
Odpowiedz
#7
Próbowałem się czegoś dowiedzieć na githubie ale nie za wiele to pomogło: https://github.com/byt3bl33d3r/MITMf/issues/221  zrobiłem co trzeba i tak to samo
Odpowiedz
#8
Jaka karta?
reinstalacja? tzn instalowałeś jeszcze raz to samo czy kali 1 -> kali 2 sana ?
Zapodaj
lspci
lsusb
llsmod
--
pzdr n0me
echo b > /proc/sysrq-trigger


Odpowiedz
#9
(12-16-2015, 23:16)n0me napisał(a): Jaka karta?
reinstalacja? tzn instalowałeś jeszcze raz to samo czy kali 1 -> kali 2 sana ?
Zapodaj
lspci
lsusb
llsmod

przeinstalowuje właśnie nty raz i na vb i normalnie tylko że teraz coś jest z repo, spróbuje rano jeszcze dać upgrady itd. Sprawdziłem tak jak u bartek35355 Zanti na androidzie działa bez zarzutu, ale do sedna
- karta t-link 722N, sprawdzałem na innej też to samo
- lspci

root@localhost:~# lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1566
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 156b
00:02.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Functions 5:1
00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 16h Processor Functions 5:1
00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1537
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 11)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 39)
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 39)
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 42)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
00:14.7 SD Host controller: Advanced Micro Devices, Inc. [AMD] FCH SD Flash Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1580
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1581
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1582
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1583
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1584
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1585
01:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)

- lsusb
root@localhost:~# lsusb
Bus 002 Device 005: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0
Bus 002 Device 003: ID 5986:0652 Acer, Inc
Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0e8f:00fb GreenAsia Inc.
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

-  lsmod
root@localhost:~# lsmod
Module                  Size  Used by
ctr                    16384  1
ccm                    20480  1
binfmt_misc            20480  1
nfnetlink_queue        24576  0
nfnetlink_log          20480  0
nfnetlink              16384  2 nfnetlink_log,nfnetlink_queue
snd_hda_codec_conexant    24576  1
snd_hda_codec_generic    65536  1 snd_hda_codec_conexant
snd_hda_codec_hdmi     53248  1
rtsx_usb_ms            20480  0
ath9k_htc              61440  0
memstick               16384  1 rtsx_usb_ms
uvcvideo               86016  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_core         40960  1 uvcvideo
v4l2_common            16384  1 videobuf2_core
videodev              131072  3 uvcvideo,v4l2_common,videobuf2_core
media                  20480  2 uvcvideo,videodev
snd_hda_intel          28672  10
snd_hda_controller     28672  1 snd_hda_intel
ath3k                  16384  0
btusb                  40960  0
arc4                   16384  4
ath9k                  90112  0
ath9k_common           28672  2 ath9k,ath9k_htc
ath9k_hw              421888  3 ath9k_common,ath9k,ath9k_htc
ath                    28672  4 ath9k_common,ath9k,ath9k_htc,ath9k_hw
mac80211              557056  2 ath9k,ath9k_htc
snd_hda_codec         110592  5 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
radeon               1495040  4
bluetooth             425984  3 ath3k,btusb
joydev                 20480  0
snd_hwdep              16384  1 snd_hda_codec
kvm_amd                61440  0
ttm                    77824  1 radeon
snd_pcm                90112  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
kvm                   425984  1 kvm_amd
cfg80211              454656  5 ath,ath9k_common,ath9k,mac80211,ath9k_htc
ideapad_laptop         20480  0
drm_kms_helper        102400  1 radeon
snd_timer              28672  1 snd_pcm
edac_mce_amd           24576  0
snd                    69632  28 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
sparse_keymap          16384  1 ideapad_laptop
rfkill                 20480  6 cfg80211,ideapad_laptop,bluetooth
edac_core              45056  0
drm                   274432  7 ttm,drm_kms_helper,radeon
pcspkr                 16384  0
psmouse               110592  0
evdev                  24576  13
serio_raw              16384  0
k10temp                16384  0
fam15h_power           16384  0
soundcore              16384  2 snd,snd_hda_codec
shpchp                 32768  0
ac                     16384  0
battery                16384  0
ccp                    32768  0
video                  20480  0
i2c_piix4              24576  0
i2c_algo_bit           16384  1 radeon
rng_core               16384  1 ccp
button                 16384  0
acpi_cpufreq           20480  0
processor              28672  5 acpi_cpufreq
thermal_sys            32768  2 video,processor
fuse                   90112  3
autofs4                36864  2
ext4                  499712  1
crc16                  16384  2 ext4,bluetooth
mbcache                20480  1 ext4
jbd2                   86016  1 ext4
dm_mod                 94208  0
mmc_block              36864  0
hid_generic            16384  0
usbhid                 49152  0
hid                   106496  2 hid_generic,usbhid
rtsx_usb_sdmmc         28672  0
rtsx_usb               20480  2 rtsx_usb_sdmmc,rtsx_usb_ms
mfd_core               16384  1 rtsx_usb
sg                     32768  0
sr_mod                 24576  0
cdrom                  49152  1 sr_mod
sd_mod                 45056  3
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
crc32c_intel           24576  0
ghash_clmulni_intel    16384  0
aesni_intel           167936  2
aes_x86_64             20480  1 aesni_intel
ahci                   32768  2
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
glue_helper            16384  1 aesni_intel
libahci                28672  1 ahci
ablk_helper            16384  1 aesni_intel
xhci_pci               16384  0
cryptd                 20480  3 ghash_clmulni_intel,aesni_intel,ablk_helper
ehci_pci               16384  0
xhci_hcd              155648  1 xhci_pci
ehci_hcd               77824  1 ehci_pci
libata                180224  2 ahci,libahci
sdhci_pci              24576  0
sdhci                  40960  1 sdhci_pci
scsi_mod              200704  4 sg,libata,sd_mod,sr_mod
mmc_core              110592  4 mmc_block,sdhci,rtsx_usb_sdmmc,sdhci_pci
usbcore               200704  10 ath3k,btusb,uvcvideo,rtsx_usb,ehci_hcd,ehci_pci,usbhid,ath9k_htc,xhci_hcd,xhci_pci
r8169                  77824  0
usb_common             16384  1 usbcore
mii                    16384  1 r8169


prawdopodobnie coś jest z firewallem tak jak wspomina gość na githubie, tylko że po instalaji na vb nie działają mi repo tak samo na normalnym, ale to instalowalem oba doslownie przed chwila więc coś może rano się zmieni

ok upgrad poszedł.Wyłączyłem UFW, dałem iptables --flush    nadal to samo, poniżej logi:

(MITMf)root@kali:~/MITMf# python mitmf.py -i wlan0mon --target 192.168.0.13 --gateway 192.168.0.1 --arp --spoof --hsts --log-level debug

2015-12-17 11:01:15 MITMf started: ['mitmf.py', '-i', 'wlan0mon', '--target', '192.168.0.13', '--gateway', '192.168.0.1', '--arp', '--spoof', '--hsts', '--log-level', 'debug']
[*]MITMf v0.9.8 - 'The Dark Side'
|
|_ Net-Creds v1.0 online
2015-12-17 11:01:15 [ProxyPlugins] Adding SSLstrip+ plugin
|_ SSLstrip+ v0.4
|  |_ SSLstrip+ by Leonardo Nve running
2015-12-17 11:01:15 [ProxyPlugins] Adding Spoof plugin
|_ Spoof v0.6
2015-12-17 11:01:16 [ARPpoisoner] gatewayip  => 192.168.0.1
2015-12-17 11:01:16 [ARPpoisoner] gatewaymac => xx:xx:xx:xx:xx:xx
2015-12-17 11:01:16 [ARPpoisoner] targets    => [IPAddress('192.168.0.13')]
2015-12-17 11:01:16 [ARPpoisoner] ignore     => []
2015-12-17 11:01:16 [ARPpoisoner] ip         => 192.168.0.24
2015-12-17 11:01:16 [ARPpoisoner] mac        => xx:xx:xx:xx:xx:xx
2015-12-17 11:01:16 [ARPpoisoner] interface  => wlan0mon
2015-12-17 11:01:16 [ARPpoisoner] arpmode    => rep
2015-12-17 11:01:16 [ARPpoisoner] interval   => 3
2015-12-17 11:01:16 [Utils] Setting ip forwarding to 1
2015-12-17 11:01:16 [Utils] Setting iptables HTTP redirection rule from port 80 to 10000
|  |_ ARP spoofing enabled
|_ Sergio-Proxy v0.2.1 online
|_ SSLstrip v0.9 by Moxie Marlinspike online
|
|_ MITMf-API online
 * Running on http://127.0.0.1:9999/ (Press CTRL+C to quit)
|_ HTTP server online
|_ DNSChef v0.4 online
|_ SMB server online

2015-12-17 11:01:18 [ARPpoisoner] Unable to resolve MAC address of 192.168.0.13
2015-12-17 11:01:23 [ARPpoisoner] Unable to resolve MAC address of 192.168.0.13
2015-12-17 11:01:26 [ARPpoisoner] Unable to resolve MAC address of 192.168.0.13
2015-12-17 11:01:29 [ARPpoisoner] Unable to resolve MAC address of 192.168.0.13
2015-12-17 11:01:34 [ARPpoisoner] Unable to resolve MAC address of 192.168.0.13
2015-12-17 11:01:37 [ARPpoisoner] Resolved 192.168.0.13 => xx:xx:xx:xx:xx:xx
2015-12-17 11:01:39 [ClientRequest] Resolving host: resolver.gslb.mi-idc.com
2015-12-17 11:01:39 [URLMonitor] Parsing host: resolver.gslb.mi-idc.com
2015-12-17 11:01:39 [URLMonitor] Host not in list: resolver.gslb.mi-idc.com
2015-12-17 11:01:39 [ClientRequest] Host not cached.
2015-12-17 11:01:39 [ClientRequest] Resolving with DNSChef
2015-12-17 11:01:39 127.0.0.1 [DNS] Proxying the response of type 'A' for resolver.gslb.mi-idc.com
2015-12-17 11:01:39 [ClientRequest] Resolved host successfully: resolver.gslb.mi-idc.com -> 54.255.183.200
2015-12-17 11:01:39 [URLMonitor] Parsing host: resolver.gslb.mi-idc.com
2015-12-17 11:01:39 [URLMonitor] Host not in list: resolver.gslb.mi-idc.com
2015-12-17 11:01:40 [ClientRequest] Modifing HOST header: resolver.gslb.mi-idc.com -> resolver.gslb.mi-idc.com
2015-12-17 11:01:40 [ClientRequest] Zapped encoding
2015-12-17 11:01:40 [URLMonitor] Parsing host: resolver.gslb.mi-idc.com
2015-12-17 11:01:40 [URLMonitor] Host not in list: resolver.gslb.mi-idc.com
2015-12-17 11:01:40 [ClientRequest] Sending request via HTTP
2015-12-17 11:02:10 [ServerConnectionFactory] Server connection failed.
2015-12-17 11:02:10 [ServerConnectionFactory] Retrying via SSL
2015-12-17 11:02:40 [ServerConnectionFactory] Server connection failed.
^C

2015-12-17 11:02:54 [ARPpoisoner] Restoring connection 192.168.0.13 <-> 192.168.0.1 with 2 packets per host
2015-12-17 11:02:54 [Utils] Flushing iptables
2015-12-17 11:02:54 [Utils] Setting ip forwarding to 0



pip freeze

(MITMf)root@kali:~/MITMf# pip freeze
beautifulsoup4==4.4.1
capstone==3.0.4
cffi==1.3.1
characteristic==14.3.0
chardet==2.3.0
configobj==5.0.6
cryptography==1.1.2
dnslib==0.9.6
dnspython==1.12.0
enum34==1.1.1
Flask==0.10.1
idna==2.0
ipaddress==1.0.15
IPy==0.83
itsdangerous==0.24
Jinja2==2.8
lxml==3.5.0
MarkupSafe==0.23
msgpack-python==0.4.6
netaddr==0.7.18
NetfilterQueue==0.6
pefile==1.2.10.post114
Pillow==3.0.0
pyasn1==0.1.9
pyasn1-modules==0.0.8
pycparser==2.14
pycrypto==2.6.1
pyinotify==0.9.6
pyOpenSSL==0.15.1
pypcap==1.1.4
python-magic==0.4.10
requests==2.9.0
scapy==2.3.1
service-identity==14.0.0
six==1.10.0
Twisted==15.5.0
ua-parser==0.5.1
user-agents==1.0.1
Werkzeug==0.11.2
wheel==0.24.0
zope.interface==4.1.3
Odpowiedz
#10
Ja mam jakiegoś broadcoma w lapku, więc to raczej nie wina sieciówki. Możliwe, że nasze routery wykrywają spoof i blokują połączenie.
Np. na swoim tp-linku nie mogę nasłuchiwać całej sieci w zantim, tylko pojedyncze urządzenia. U kumpla nasłuch wszystkich urządzeń działa w 100%.
Nie jestem ekspertem, ale możliwe że problemem jest właśnie router.
Odpowiedz


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Pyrit batch problem ? illegal 8 1,622 03-18-2014, 2:24
Ostatni post: Tester
Backtrack.pl Problem z kartą sieciową w backtrack 5 (VirtualBox) facebookmati 11 3,254 02-13-2014, 18:05
Ostatni post: pezed
Backtrack.pl Problem z uzyskaniem handshaka:C Wardriveritp 28 3,303 01-28-2014, 12:06
Ostatni post: Wardriveritp
  subterfuge problem z użytkowaniem. mario2255 1 912 05-06-2013, 20:14
Ostatni post: r4f4l24x
Sad Problem z internetem WIFI EMC 3 971 04-21-2013, 10:40
Ostatni post: EMC
  Zmiana Mac problem z łączniem mario2255 4 1,143 04-04-2013, 14:47
Ostatni post: rafal13-50
  skopiowane pliki cap problem mario2255 4 1,053 03-29-2013, 21:27
Ostatni post: mario2255
Question Problem z złamaniem hasła vernoth 31 4,996 03-21-2013, 18:44
Ostatni post: n0me
  Problem z pingiem TekMast 11 2,162 03-19-2013, 20:39
Ostatni post: TekMast
  Problem z Brute Force mtrance 3 966 03-15-2013, 11:52
Ostatni post: Tommy

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości
stat4u