Ocena wątku:
  • 1 głosów - średnia: 5
  • 1
  • 2
  • 3
  • 4
  • 5
Instalacja Metasploit na Debianie.
#1
Witam,
próbuję zainstalować metasploita na debianie (przez ssh) i kiedy wpisuje git clone https://github.com/rapid7/metasploit-framework to prosi w podanie loginu i hasła. Już jakiś czas szukam w necie rozwiązania, ale nie mogę znaleźć.
Wie ktoś może jak zainstalować tego metasploita?
The quieter, the better.
Odpowiedz
#2
Pobrałem to z githuba i skopiowałem przez ssh. Podczas instalacji (bundle install) wyskakuje błąd przy mini_portile 0.6.2. Próbowałem gem install nokogiri .... - czyli to co tam proponowali ale też błędy i kończy działanie. 

   
   
The quieter, the better.
Odpowiedz
#3
Zainstaluj wg. tego:
http://www.darkoperator.com/installing-m...-in-ubunt/
Kto mieczem wojuje - ten często zwycięża.
Odpowiedz
#4
W pliku gem_make.out masz o co mu biega
I nie masz libxml2 >= 2.6.21
Wszystko napisane
--
pzdr n0me
echo b > /proc/sysrq-trigger


Odpowiedz
#5
Witam ...
Aby zainstalować najpierw aktualizację zrób
Kod:
sudo apt-get update

lub/or

sudo apt-get upgrade

potem

Kod:
cd /opt

git clone https://github.com/rapid7/metasploit-framework.git

cd metasploit-framework
Odpowiedz
#6
Kod:
cd /opt
git clone https://github.com/rapid7/metasploit-framework.git
#WiFiSlax - Po wydaniu tego polecenia prosiło mnie o hasło (jak ostatnio próbowałem), ale teraz właśnie pobiera Smile zobaczę co będzie Smile
#n0me - nie mam pliku gem_make.out i mam libxml2 w wersji 2.9.1

edit
mam jednak gem_make.out Big Grin
ale z tym libxml2 to nie wiem co zrobić, bo dpkg -l | grep libxml2 pokazuje wersje 2.9.1 a to jest >= 2.6
The quieter, the better.
Odpowiedz
#7
Dobra teraz doczytałem choć to na czerwono jest Wink

aptitude search nokog

Zainstaluj któryś.
W debianie większość paczek już jest i nie zawsze trzeba kombinować, jak tu np z gem install
--
pzdr n0me
echo b > /proc/sysrq-trigger


Odpowiedz
#8
Zainstalowałem i też nie idzie dalej :/
The quieter, the better.
Odpowiedz
#9
[Wideo: https://www.youtube.com/watch?v=OHS1zioWGhY]


Prawidłowa instalacja Metasploit
Odpowiedz
#10
(02-09-2015, 15:29)Xenovious napisał(a): Zainstalowałem i też nie idzie dalej :/

No to peszek... a tak serio to na czym teraz sie wykłada?
--
pzdr n0me
echo b > /proc/sysrq-trigger


Odpowiedz


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Metasploit gui hasło Trox 0 537 02-26-2016, 19:01
Ostatni post: Trox
  Darmowy pdf Metasploit Penetration Testing Cookbook perlikk 1 1,336 02-20-2015, 13:08
Ostatni post: Xenovious
  metasploit kilka pytań moralezblack 7 1,470 01-21-2015, 0:24
Ostatni post: n0me
  Instalacja Metasploit Anh3doX 0 1,605 09-07-2014, 20:33
Ostatni post: Anh3doX
  [Metasploit] Exploity podchodzące pod port 445 Kamil++ 12 2,748 06-04-2014, 13:47
Ostatni post: Kamil++
  Metasploit - aktualizacja pakietów Bysiek 3 1,779 02-18-2014, 15:48
Ostatni post: Bysiek
Question metasploit zapytanie... killerro 3 1,226 12-26-2013, 0:43
Ostatni post: Xenovious
  Baza msf3 w Metasploit Anh3doX 4 1,523 10-31-2013, 21:43
Ostatni post: Anh3doX
  Metasploit - Windows XP SP3 PL Zagroda 4 1,535 10-30-2013, 3:19
Ostatni post: Zagroda
  Metasploit vs exploit-db.com Anh3doX 5 1,547 10-16-2013, 21:19
Ostatni post: Drareg

Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości
stat4u