Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
MSFCONSOLE -Permission denied
#1
Kali Linux PREMIUM CLEAN 1.0.2c - moja wersja systemu. Postawiona na stacjonarce na zaszyfrowanym dysku zgodnie z instrukcja zamieszczona na glownej stronie. Wszystko dzialalo swietnie gdy nagle przy probie uruchomienia msfconsole dostaje blad:
Kod:
/usr/bin/msfconsole: 19: exec: /opt/metasploit/apps/pro/msf3/msfconsole: Permission denied
Jestem pewien ze to ja cos namieszalem w systemie ale nie moge znalezc rozwiazania tego problemu . Updatowalem , upgradowalem ,reinstalowalem ,googlowałem, resetowalem komputer niestety dalej nie moge uruchomic Metasploita. Nadmienie ze wszystko jest robione z root'a i nie zmienia to niczego w mojej sytuacji.

Czy jest ktos kto moglby mnie w jakikolwiek sposob nakierowac na rozwiazanie ?
#2
Pokaż:
mount
ls -al /opt/metasploit/apps/pro/msf3/
#3
mount:
Kod:
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=207494,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=661436k,mode=755)
/dev/mapper/sda5_crypt on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1322860k)
/dev/sda3 on /boot type ext4 (rw,relatime,data=ordered)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=0,group_id=0)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
ls -al /opt/metasploit/apps/pro/msf3/:
Kod:
drwxr-xr-x  10 root root  4096 paź 28 21:42 .
drwxr-xr-x 516 root root 20480 paź 28 22:11 ..
-rw-r--r--   1 root root    68 paź 17 20:49 .apt
-rw-r--r--   1 root root    50 kwi 15  2013 build_rev.txt
drwxr-xr-x   2 root root  4096 paź 28 20:23 .bundle
drwxr-xr-x  23 root root  4096 paź 28 21:42 data
-rw-r--r--   1 root root  1507 kwi 15  2013 Gemfile
-rw-r--r--   1 root root  1427 kwi 15  2013 Gemfile.lock
drwxr-xr-x  23 root root  4096 paź 28 21:42 lib
drwxr-xr-x   8 root root  4096 paź 28 21:42 modules
-rw-r--r--   1 root root  7115 mar 26  2013 msfbinscan
-rw-r--r--   1 root root  7613 mar 26  2013 msfcli
-rw-rw-r--   1 root root  4573 kwi  1  2013 msfconsole
-rw-r--r--   1 root root  2543 mar 26  2013 msfd
-rw-r--r--   1 root root  2768 mar 26  2013 msfelfscan
-rw-r--r--   1 root root  7114 mar 26  2013 msfencode
-rw-r--r--   1 root root  2437 mar 26  2013 msfmachscan
-rw-r--r--   1 root root  5104 mar 26  2013 msfpayload
-rw-r--r--   1 root root  4421 mar 26  2013 msfpescan
-rw-r--r--   1 root root  4175 mar 26  2013 msfrop
-rw-r--r--   1 root root  2123 kwi  1  2013 msfrpc
-rw-r--r--   1 root root  3037 mar 26  2013 msfrpcd
-rw-r--r--   1 root root  8535 kwi  5  2013 msfupdate
-rw-r--r--   1 root root 13764 mar 26  2013 msfvenom
drwxr-xr-x   2 root root  4096 paź 28 21:42 plugins
-rw-r--r--   1 root root  2060 kwi 15  2013 Rakefile
-rw-r--r--   1 root root   135 cze 20  2011 README_XSSF
drwxr-xr-x   6 root root  4096 paź 18 06:22 scripts
drwxr-xr-x   5 root root  4096 paź 28 21:42 tools
drwxr-xr-x   3 root root  4096 paź 18 06:22 vendor
#4
@Up
okej to bylo glupie i dziecinnie proste dzieki Twojej podpowiedzi zauwazylem ze msfcosnole nie ma prametru x wiec dodalem go chmod +x aczkolwiek nie naprawilo to moich problemow...
Kod:
[-] Failed to connect to the database: FATAL:  password authentication failed for user "msf3"
FATAL:  password authentication failed for user "msf3"

/opt/metasploit/apps/pro/msf3/modules/exploits/freebsd/local/mmap.rb:14: warning: toplevel constant File referenced by Msf::Post::File
/opt/metasploit/apps/pro/msf3/modules/payloads/singles/nodejs/shell_reverse_tcp.rb:30:in `initialize': uninitialized constant Msf::Modules::Mod7061796c6f61642f73696e676c65732f6e6f64656a732f7368656c6c5f72657​6657273655f746370::Metasploit3::ARCH_NODEJS (NameError)
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/payload_set.rb:189:in `new'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/payload_set.rb:189:in `add_module'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.rb:60:in `on_module_load'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:207:in `load_module'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:262:in `block in load_modules'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:52:in `block (2 levels) in each_module_reference_name'
    from /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:80:in `block in find'
    from /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:79:in `catch'
    from /opt/metasploit/apps/pro/msf3/lib/rex/file.rb:79:in `find'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:43:in `block in each_module_reference_name'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:27:in `foreach'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/directory.rb:27:in `each_module_reference_name'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/modules/loader/base.rb:260:in `load_modules'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.rb:99:in `block in load_modules'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.rb:97:in `each'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/loading.rb:97:in `load_modules'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/module_paths.rb:54:in `block in add_module_path'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/module_paths.rb:53:in `each'
    from /opt/metasploit/apps/pro/msf3/lib/msf/core/module_manager/module_paths.rb:53:in `add_module_path'
    from /opt/metasploit/apps/pro/msf3/lib/msf/base/simple/framework.rb:168:in `init_module_paths'
    from /opt/metasploit/apps/pro/msf3/lib/msf/ui/console/driver.rb:228:in `initialize'
    from /opt/metasploit/apps/pro/msf3/msfconsole:169:in `new'
    from /opt/metasploit/apps/pro/msf3/msfconsole:169:in `<main>'
Zastanawia mnei dlaczego domyslnie te pliki nie maja atrybutu x pomimo tego ze byly reinstalwoane , updatowane itp.
#5
Mozesz mi pokazac ten opis wedlug ktorego wykonales instalacje?

Dziala ci serwis metasploita?
#6
chodzi o instalacje systemu czy Metasploit ?
jezeli chodzi o ssytem to zwykla bootowalna plyta i zgodnie z opisem link
a co sie ma do Metasploit :
1.napoczatku sprbowalem prostego apt-get remove a pozniej apt-get install ale nie przynioslo to zadnego skutku
2.zauwazylem ze pomimo apt-get remove folder metasploit dalej istnieje weic w nadzieji ze to cos zmieni usunalem cala jego zawartosc liczac na efekty jednak po ponownej instalacji dalej to samo
3. probowalem jeszcze usunac pliki metasploita z /usr/bin lecz po ponownej instalacji bylo to samo
4. Reiisntalowalem rownziez cale framework2 za pomoca apt-get
5. Probowalem zrobic to rowniez za pomoca LINK czyli za pomoca komendy "./uninstall" ale system nie rozpoznaje tej komendy
Nadmienia rowniez ze apt-update i upgrade byly robione
Nie wykluczam ze cos zrobilem zle w reinstalacji...

Serwery metasploit dzialaja i sie lacza.

Do ciekawszych rzeczy nalezy zaznaczyc ze wszystkie pliki ktore powinny byc wykonwyalne w folderze Metasploit'a (msfconsole,msfupdate itd.) Wyrzucjaa ten sam blad : Permission denied.
#7
Trzeba bylo używać opcje "purge" i nie usuwać calego foleru… ale sprawdź czy dziala serwis metasploita.
Bo komuniakt dotyczy bledu przy polaczeniu.
#8
Kod:
~# service metasploit start
[ ok ] Starting Metasploit rpc server: prosvc.
[ ok ] Starting Metasploit web server: thin.
[ ok ] Starting Metasploit worker: worker.
~# service metasploit status
[ ok ] Metasploit rpc server is running.
[FAIL] Metasploit web server is not running ... failed!
[ ok ] Metasploit worker is running.
'
i tu jest cos dziwnego... co mozna z tym zrobic ?
@EDIT
Kod:
~# service metasploit status
[FAIL] Metasploit rpc server is not running ... failed!
[FAIL] Metasploit web server is not running ... failed!
[ ok ] Metasploit worker is running.
Po kilkudziesieciu sekundach otrzymuje o dziwo taki wynik...
Po restarcie serwisow metasploita wszystko jest znowu ok
Kod:
~# service metasploit status
[ ok ] Metasploit rpc server is running.
[ ok ] Metasploit web server is running.
[ ok ] Metasploit worker is running
a po krotki czasie...
Kod:
~# service metasploit status
[FAIL] Metasploit rpc server is not running ... failed!
[FAIL] Metasploit web server is not running ... failed!
[FAIL] Metasploit worker is not running ... failed!

Co sie dzieje ?!
BTW. reinstalacja za pomoca purge rowniez niczego nie zmienia...
#9
@EDIT
okej reinstall systemu wszystko naprawil nie chcialo mis ie z tym bawic do usuneicia...


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości
stat4u